Maps Made Easy Drones Made Easy

Supported Hardware

Tudor -

Map Pilot for iOS relies on the DJI SDK for hardware control and video transmission. That means we can only support the hardware that DJI adds support for.

Support List:

  • Mavic Pro
  • Mavic Air
  • Mavic 2 (Pro, Zoom, and Enterprise - No SMART CONTROLLER support)
  • Phantom 4
  • Phantom 4 Pro * (v2 included)
  • Phantom 4 Advanced
  • Phantom 3 Professional 
  • Phantom 3 Advanced
  • Phantom 3 Standard 
  • Inspire 1
  • Inspire 1 Pro
  • Inspire 2
  • Matrice 100 (M100)
  • Matrice 200 (M200)
  • Matrice 210 (M210, including V2)
  • Matrice 210 RTK (M210RTK)
  • Matrice 600 (M600)
  • Matrice 600P (M600P)

Supported External Cameras:

  • DJI X3
  • DJI X5
  • DJI X4S
  • DJI X5S
  • DJI X7 (Map Pilot Business-level only)
  • Sony a7R, a7R II, and a7R III only with Drones Made Easy Ninja OBC trigger board*
  • Sony A6000 only with Drones Made Easy Ninja OBC trigger board*
  • Sony Multispectral Camera (MSZ-2100G) as part of the Drones Made Easy and Sony Smart Agriculture Solution

* Matrice 200/210/600/600P with Sony a7R and other custom camera sensors will require a Drones Made Easy custom trigger board that will only be sold as fully integrated kits built by Drones Made Easy. Email for more details and read about the Ninja OBC here: https://support.dronesmadeeasy.com/hc/en-us/articles/115000617223-What-is-the-Ninja-On-Board-Computer-

* Phantom 4 Pro v2 is supported. Phantom 4 Pro Plus version is not supported.

DJI makes a lot of firmware and SDK changes and they are not always backwards compatible. We try our best to stay on top of these changes but if any issues are encountered on supported aircraft, please give us a detailed report so we can try to fix the issue.

X5 RAW is not explicitly tested with and is not necessarily supported. 

Have more questions? Submit a request

Comments

  • Avatar
    Zane

    From the Github page for the SDK:
    P4P v2.0 support should come in the iOS SDK v4.6. v4.5.3 was just released to support an app-store rejection issue. I have not heard anything concrete on when v4.6 will be released.

  • Avatar
    Tudor

    Map Pilot version 2.8.3 has been released and supports the Phantom 4 Pro v2.

  • Avatar
    Daryl W-M

    Hi. Any idea when you'll be able to add support for the Spark?

  • Avatar
    Zane

    We do not plan on supporting the Spark due to its limited image quality and super slow rolling shutter.

  • Avatar
    Adam Cron

    Will this be compatible with P4RTK at some point?

  • Avatar
    MINGOS FERNANDEZ

    Hi, Have an estimated date for launch to support the Phantom 4 RTK.
    Greetings.

  • Avatar
    HFM UAV

    Hi there, when we will get update of Tag Pilot? We tested our Phantom 4 Pro v2 in 17 Apr 2019 and it did not work. It does not support Marvic 2 Pro too. Thanks,

  • Avatar
    David Washington

    Good Morning Drone Community. Does the Map Pilot App work with the new DJI Smart Controller?

  • Avatar
    Zane

    The Smart Controller does not allow external connections to iOS devices so Map Pilot will not work with it.

  • Avatar
    Angel Tony Dl

    Amigo tengo un phanton 4 advanced el programa no me sirve se corta en todo momento hago el plan de vuelo y el dron no se eleva q puede ser eso

  • Avatar
    Adamastor

    "TudorAugust 17, 2016 17:34
    DJI has not added support for the Z3 camera to the SDK. We can't add it until they do so."

    Hello there...
    I have damaged my X3 camera and are now basically forced to use my Z3 with my Inspire 1.
    I also realise that all my current equipment are basically EOL, but I still need to squeeze a little more out of the I1 before it becomes a rather expensive book end...

    After starting up my MapPilot for the first time in years, I notice you guys included a "custom camera" setup.
    Do you perhaps have the manual settings I can use for my Z3 please?

    Kind regards and thanking you in advance.
    HB

  • Avatar
    Veha La

    I got error Exited Programme Flights in both my Phantom 4 Pro V1 and V2. What could be wrong.

    Error screenshot: https://ibb.co/Srt6LQW

  • Avatar
    Dariusz Gozdowski

    Can I expect support of Phantom 4 Multispectral in the future?

Powered by Zendesk