Post

3 followers Follow
0
Avatar

KML upload on iPhone with iOS 13

Map Pilot has been my preferred mission planning app since i started in drones 4 or so years ago but I have had mixed success with getting KML files onto Map Pilot over the years. With the latest iOS update I cannot even see a way to try to get them uploaded. Previously Map Pilot was an option when trying to share or copy a KML file from an email. Now Map Pilot icon is not an option through this method. Can't see any settings on my phone to change that. If there is a way to do KML upload on iOS 13 I would love to know. Look forwards to hearing from you.

Kind regards

James

Info

Official comment

Avatar

I just tested it and it still seems to work. You might have to choose "More" at the end of the default list to bring up the rest of the things that can open the KML. This is on 13.1.2. 13.2 might be different. iOS 13 is hands down the worst iOS update we have had to do in 5 years. 

Please let us know if you are unable to do it and what version of iOS you are using.

Zane
Comment actions Permalink

Please sign in to leave a comment.

17 comments

0
Avatar

I’m on 13.1.2 also. Map pilot doesn’t appear in ‘more’ section either. Might be something specific to phone settings I guess. Is it worth removing then reinstalling app?

...

just reinstalled and no joy. It won’t let me log back into account either now, going backwards! 

Info 0 votes
Comment actions Permalink
0
Avatar

What version of Map Pilot? You should be using 4.1.2 at this point.

Zane 0 votes
Comment actions Permalink
0
Avatar

Yes, on Map Pilot 4.1.2. Opening it from email attachment. The only way I can get any connection to Map Pilot is by selecting 'Save to files' lower down on 'Share file' option. That would let me save file either in 'SDK_Logs' or 'FlightRecord' folder, but nothing else.

On the separate issue of logging back in, i have sorted that but seem to have lost my terrain following subscription, I assume that this can be reactivated?

Info 0 votes
Comment actions Permalink
0
Avatar

As long as you are logged in to Maps Made Easy, which can be done from the Settings screen too, you can use Terrain Awareness. There is nothing to activate. 

Since you deleted the app you may need to press the "Restore" button if you are prompted to buy the feature again. This will restore all previous purchases associated with the logged in Apple ID. 

You could also just press 'Buy' safely because you can't be charged more than once for any of our apps or add-on features.

Zane 0 votes
Comment actions Permalink
0
Avatar

Great. Thanks. That is the terrain awareness restored. Now just the KML to sort! Any more ideas or is it a case of my phone not playing ball?

Info 0 votes
Comment actions Permalink
0
Avatar

It could be that your KML isn't compatible. You can email it to us to check if you want. Or try with a simple KML created in Google Earth.

Also, make sure it is a KML file, not a KMZ file. People make that mistake a lot. KMZ files are not supported. 

Zane 0 votes
Comment actions Permalink
0
Avatar

Yep, definitely KML and loads fine in Google Earth. Loaded it in and then saved it from Google Earth just to check but no difference. I'll email it through to you just in case - whats best email?

Is it possible I have some odd security setting on the iPhone? I've looked through to check that nothing obvious is enabled (or disabled) but cannot see anything. I would try on the ipad but that is only an iPad Mini 2 and probably won't cope anyway.

Info 0 votes
Comment actions Permalink
0
Avatar

mapping@dronesmadeeasy.com

Just because it will open in Google Earth doesn't mean it will open in Map Pilot. The KML can't be heavily nested or have a bunch of advanced features. 

Draw a simple polygon in Google Earth and save that as a KML to test with. If that works you would know it is an issue with your KML and you can likely simplify it a bit to get it to work.

Zane 0 votes
Comment actions Permalink
0
Avatar

Just emailed you the KML file. Tried a simple new polygon in Google Earth but still doesn't work. 

Info 0 votes
Comment actions Permalink
0
Avatar

The KML file was nested two folders deep which doesn't work. 

I dragged the 'no name' later up to the top level, so it is in Temporary Places, then right click to "Save Place as..." and choose a KML file type. This file works.  

Zane 0 votes
Comment actions Permalink
0
Avatar

Right, that works well on the ipad but not the iphone, must be a setting somewhere that stops it from working, or something to do with iOS 13 as the iPad has 12 on still. Guess the test would be to update the ipad and see if it still works.

Info 0 votes
Comment actions Permalink
0
Avatar

Don't update to iOS 13 if you don't have to. That screenshot was from an iOS 13.1.2 iPhone. 

Zane 0 votes
Comment actions Permalink
0
Avatar

Had quick search and it seems that other geospatial apps that use KML etc are also having issues:

https://advrider.com/f/threads/iphone-ios-13-gpx-kml-import-open-in-bug.1409148/

https://forums.developer.apple.com/thread/118932

It seems to not cause some people an issue but others it does. Maybe some clash with other apps?!?

Thanks for your assistance, but by the looks of it, it may be something I have to wait for Apple to sort.

I’ll keep trying some other options (removing some other apps etc) but am not hopeful. If you can think of any other way forward let me know.

Cheers

Info 0 votes
Comment actions Permalink
0
Avatar

After changing various things I have managed to get the kml in but to be honest not sure how. It has just appeared in the file manager section. Its a mystery. Should I, in theory be able to have a number of kml files stored in there at same time?

Thanks

Info 0 votes
Comment actions Permalink
0
Avatar

The KML import is broken in 4.1.2

Opening within dropbox doesn't work anymore like it used to.

The only way I found that works is to copy the kml file to the map pilot folder and then it appears in the File Manager.

George 0 votes
Comment actions Permalink