2 followers Follow

SYS Error, Check App

So I was super excited to take the DJI Mavic Pro out for a mapping mission yesterday. I had done a small test flight around my home and everything seemed to go okay. 


Once I get out there and start flying, there was a recurring error. 

The drone would take off, get to the required height(400 Feet). And take off to its first waypoint. Then, right after heading to this waypoint; the controller would start flashing "SYS ERROR, CHECK APP".

After this, I would have to land the drone, reupload the mission and start again and things would go fine for a couple of passes. Then this would happen again. What should have been a 3-4 hour ordeal eventually turned into 5 hours and I only got 1/3 of the area completed. 


Needless to say, after paying $10 for the premium version of the app; I was super disappointed. I didn't want to have to pay $150 for a month of Drone Deploy, but I guess that is what I will have to do to get the task completed. I couldn't find anywhere online what this error could mean or how to fix it. I would think that there could be a way to resume the mission after the drone regains GPS lock, but it doesn't seem like this is a possibility.


As far as fixes. I feel like I tried everything. 

Connectionless-Mode, On/Off

Drone In Sport/Normal Mode

Varying Heights, from 300-700 Feet



Other than this annoying issue. I love the app, but it simply won't work for larger missions. If there is a fix. Please let me know.



DJI Mavic Pro

iPhone 8 (No Other Apps Running At All)

Ashton Miller

Official comment


That sounds like an aircraft error to me. Did you try flying lower? Do you have your aircraft set to not exceed a certain height in DJI Go?

If you look at the 'DJI Diagnostics' column of your log files there are some errors that are concerning... Repeated "Aircraft GPS Error" and "Compass abnormal" are not good and point to either hardware problems or a bad compass or IMU calibration. 

Map Pilot does allow you to resume your mission from where you left off. If your aircraft can't fly waypoints successfully for some reason that is going to be a problem.

I would recommend doing some smaller controlled tests and learning your way around things before tackling a large mission like you are attempting. 

Comment actions Permalink

Please sign in to leave a comment.



Okay, thank you very much for your response. I looked into the log files and found the Compass Abnormal line that you were talking about. I tried the other app, and the same error persisted. 


So I opened the DJI app and calibrated the compass. BOOM! No more error just got done flying a smaller mission under 250 points for a test and the whole thing was completed without an issue!


Thank you for your help. And if you are reading this with the SYS ERROR, CHECK APP error. Make sure to calibrate your drone compass through the DJI app before your flight.

Ashton Miller 0 votes
Comment actions Permalink