Post

5 followers Follow
0
Avatar

Similar weird experiences as with Jim Ward + more

Setup latest FW for inspire 1 PRO with the 15 MFT lens

App is on the 2.1.4 build 08162016

Disclaimer: We are not new at this and used the app in many versions ago with older I1X3 and did not experience this in the past. These errors are appearing since 2.1 We are flying multi battery missions only due to the large areas to cover over 45 km.

Issues:

1. Flight not following the blue abandonment point and continuing on the new grid line past the point making the hole in the project. All this is while taking the photos while flying toward the wrong resume point. This happens randomly, it could wrk for two flights and the third one would f'it up.

2. Loosing current home location randomly

3. Loosing camera config mid flight (camera preview goes grey) and stops taking pics. After we lan and reset it goes back to normal.

4. Mission loosing the mission data after aircraft lands and stays off for a period of longer than 10-15 min between battery changes.

5. "Home point farther than 2000 m....." warning message popping out randomly.

 

 

Now some oldie but goodie recommendations for fixes

1. Lots of loiter time after the mission upload, wasting batteries and doing the "dance" changing headings after reaches the mission altitude.

2. While the aircraft is on the ground while we change batteries we like to zoom on the map and get a better look on the coverage, this pinch action causes the flight lines to rotate. Mission should be locked until completed or the user exits.

 

I wish you guys make a pro version and charge more for it but make it stable and no fuss. Is that possible with the DJI SDK?

We have to deal with all sorts of crap in the field and fixing apps while working is not desirable. 

Thanks 

Dan

Daniel Helc

Official comment

Avatar

This Home Point and connection issues are apparently a problem with the Inspire Pro as we have only had reports of it happening with that. We don't have one to test with right now. The "Adjacent Point further than 2000 m" error happens when there is no valid Home Point.

Can you describe the issue with the mission data being lost a little better? When the app is closed it will load the last known mission data from a saved file. The aircraft will backtrack along flight path for one waypoint depending on conditions when the app closed.  

If you manually land the aircraft instead of letting land on its own it will get out of sync with the completed waypoints. 

If you must manually fly it home and land it make sure you switch back into F mode before you hit the ground so things will get set up properly. If it isn't in F mode the app does not get updates.

We cannot affect the loiter time. The "dance" is it going to a waypoint that is a few meters away from the takeoff point. It might account for 10 seconds.

If you ever have questions on where the programmed flight plan is heading make sure you have the "Display Adjacent Missions" checked in the settings so it will display the blue flight preview line. That line is the exact path that will be flown as it is programmed into the aircraft. 

The mission is locked between battery changes. If you are experiencing otherwise please carefully document the steps to reproduce it so we can address the issue. We have tested this in new and cached missions and are not seeing it be unlocked until the mission is completed.

 

 

Zane
Comment actions Permalink

Please sign in to leave a comment.

8 comments

0
Avatar

Ok, home point issue checked. I will try the work around with either reset or open the DJI GO and set the home point. 

Pic 1: Mission error: Aircraft just returned and you can see how the last two flights were ok and the previous one did not continue at the abandon point. No difference how I operate it between the flights. At the end of the mission I don't switch the PAF while in F, I can manually control the UAV just fine.

 

Pic 2: Random mission data loss. First there was the usual message popped up during the flight that aircraft camera recognition and MMW warning message the usually opens when the map is opened the first time.

 

Pic 3: Home point loss. This happens randomly too. One flight on the multi battery mission is ok another might not be ok.

 

In short I don't trigger the PAF switch to P unless the threat to UAV and manually fly it to the landing area in after it starts the descend sequence due to the obstacles. As you know home point might be anywhere within the 5 m radius.

 

The "dance" does take 10-15 sec and in hot and humid conditions that could mean 10-15% of battery life for the take off, mission load, ascend to alt, do the dance and only then fly to the next mission point. 

I will take a video of it and post it so you can see. We use pix4D software to process imagery and one of the best practices is to fly the whole mission from one location if possible, which means hight traverse times. Can you please test that? We still stay with in 1km visual range.

NIE TO HAVE:

1. Nice to have is offline cache for the mission so we can resume once the IOS device battery dies. 

2. IOS device charging while running the mission. I tried dual plugs and extra battery pack options and we can either connect to the drone to fly the mission or charge but not both at the same time.

 

 




Daniel Helc 0 votes
Comment actions Permalink
0
Avatar

Pic 1: Yes, you can control it fine but the app isn't getting updates from the aircraft anymore so it is going to get out of sync.

Pic 2: This looks like a normal signal loss issue. It could have to do with the fact that you are on a pretty old device and might be running low on system resources. 

Pic 3: Can't really tell anything from this. I just looks like you aren't connected. This isn't the home point issue, this is just a connection issue. 

Map Pilot will only allow the aircraft to take off if it is within 10 meters of the defined home point. If your aircraft can't get a home point fix while it is on the ground, it isn't going anywhere.

Nice to haves:

1. Already in there.

2. This is how the iOS devices work. One connection at a time. 

Zane 0 votes
Comment actions Permalink
0
Avatar

Is the waypoint issue happening on Terrain Aware missions or just flat ones?

Tudor 0 votes
Comment actions Permalink
0
Avatar

Those images are exactly the problems I'm facing also and called them "Graphical Issues". I'm doing everything as recommended. The blue point is not respected (even after "Flight n complete message"). MP says that will resume in the abandoned point and after goes to a random point and takes pictures on it's way, just like the images uploaded By Daniel. I'm experiencing all Daniels Problems with an Inspire 1 (not Pro), X3 and Ipad Air2 and without Terrain Awareness activated.

I lost some confidence in Multi-Battery missions for now but, even so, I've made an extensive number of surveys since last Thursday using single battery plans stitched beside others to cover all my area. It's not as comfortable as a real multi-battery mission but it works. Using single missions MP was the best companion I could get to have the Job done. I hope that you can nail these issues. 

rhenriques11 0 votes
Comment actions Permalink
0
Avatar

Zane, sorry to tell you but it's the coding in the Map Pilot that is buggy. Did the job today with difficulties but regardless had a bit of time to test out the system. So here it is in pics:

This is on iPhone SE, so everything is latest

1. DJI GO (home point all good)

2. Switch (PAF) to F, turn off the DJI GO and launch Map Pilot. Plot the mission and we are all good.....

 

3. One of support guys commented to upload from the ground.....No Go

4. Take off, click upload everything looks g....Not Good

5. Clicked no and closed the app. (PAF) is still in F. Opened Pix4D capture

Opened the mission to launch.

Look at the Homepoint checkmark. This is ready to go.....

 

Soon, boys and girls at MME, please take a look at the code something is off here. Also hopefully you are aware that FW for I1PRO is different. I am not sure how and if the SDK is diff.

 

Trying to trouble shoot one thing at the time. Once this is working I will test your suggestion on not touching the drone in the multi mission to see if that makes the difference with the abandon point issue. I have the feeling that there is the problem in code as well.

 

Cheers and keep up the good work. (Watch out for parallel logic) 

 

Daniel Helc 0 votes
Comment actions Permalink
0
Avatar

Map Pilot is quite a bit more complex than most other apps and it does things a bit differently to add safety and accuracy to the flight and collected data. If it wasn’t more complex and offer more functionality you wouldn’t likely spend so much time writing up bug reports if it didn’t offer you something you can’t get elsewhere. We try to address every issue that is raised with the intended operation of the app.

 

We do, however, take issue with the way this story is being told…

 

If you get to the point where the “Inspire 1 Pro must take off manually before starting mission.” error comes up, that means you have a valid Home Point since that check is done after the Home Point check at the time of pressing Upload. Note in your picture 3 that the range is 0 ft. That is because it is in the location where the Home Point was set. All you needed to do was take off. I am pretty sure that worked… 

 

Picture 4 clearly did not happen directly after Picture 3 but instead happened some time after because you can see the battery percentage in the screen battery has gone down from 50 something to 40ish and the aircraft seems to have moved. This was likely an issue after a flight or two. Note that the aircraft’s range (distance from the Home Point) is 11 meters in Picture 4. This is not inside the 10 m limit that we deem to be a safe deviation from the Home Point. That is why the Home Point warning was shown in Picture 4. We should probably add a specific message about this case but we never expected people to be landing so far from the starting point. This is another problem with manual landing… 

 

For the message that says “Home Point Warning: The Home Point is not currently set for this location” the operative phrase is “for this location”. Map Pilot checks that the currently set home point is within 10 meters of the drones’s currently reported location. Yes, it is easy to have a check to see if there is a Home Point set and show a green check mark. But where is that Home Point? We have seen them be WAAAAY off of where they should be and this tends to cause issues. Bad ones. In the case of Picture 4, the Home Point was 11 m away. What if it was 11 km away? It happens.

 

Yes, we realize that the Inspire Pro firmware is different. The Inspire 1 Pro is weird in that it is required to be in the air for takeoff. The I1P is a system that we do not do much validation with due to its cost and relative rarity of use. With nearing infinite configuration options, lots of aircraft to support and the need to put training wheels on things so people don’t lose their aircraft, we have to make priorities. We are sorry you think we are a bunch of idiots that write crappy code but the reality is we are a small company with limited resources and we put the testing where the money is. That being said, the app did nothing that it wasn’t supposed to do in any of these scenarios.

 

Thank your for the detailed reporting, it really is appreciated. (But please, watch out for non-linear story telling)

Zane 0 votes
Comment actions Permalink
0
Avatar

@Zane

Sorry, I attached the wrong pic 4 (see below battery at 66%). This error happened a bunch of times during the test. 

10 m range noted. Did not know that. The older version did not warn about this. We would manually launch the UAV to 50m alt and quite bit away (20-30m) from the ground launch point and it worked before. So no worries will change the ops procedure.

Also software testing on the I1P noted as well. I did not know that either. If you need some help let me know and I will feed the info off-line. I used to be a software dev. 

It would be nice to have perhaps 20m for safety. We operate in difficult to access areas and the launch pad is 4x4 ft plywood ramp and typically there is no much room for manuvering on the sides.  As you know DJI GPS system is fairly inacurate i relative terms to 100x more expensive units and will bring it back to the launch pad accurately 1 in 50 times. Most of the time the pilot will need to adjust the horizontal path to guide it to the ramp while descending automatically at the same time. This minor adjustment while still in F (PAF) should not disturb the mission.

As I mentioned there a bunch more problems to be solved, but we can do it one at the time. I agree your solution is the best out there for this type of UAV unit that is why I am putting the effort to let you know. I don't think you guys are idiots, I don't know any of you. I just think the coding is not tight and obviously not tested as in the real-life situations. Most small shops use their own dev/tester in house which creates a test bias, n'es pas.

 




Daniel Helc 0 votes
Comment actions Permalink