Post

1 follower Follow
0
Avatar

I lost my Inspire yesterday using Map Pilot 2

Yesterday, I tried to fly a standard monthly survey with my Inspire 1.2.  I downloaded the latest Map Pilot, intending to fly the survey first, then test out the terrain following features.

I was using manual camera exposure control... it took some time to figure out that the settings had moved to a pull down menu from the top of the screen.  A minute or two into the survey, I realized that the camera menu was blocking the status bar at the top of the screen, that showed the signal strength, distance, direction, etc.  I tried to dismiss the camera menu, but couldn't figure out how to make it go away to make the flight status visible.

For example, if you pull down the settings pull out menu, then touch the overlap item, pullout menu shows options to increase or decrease the overlap.  If you swipe up to get back to the basic status bar at this point, you can't - you get only the overlap controls; the flight status bar is completely hidden.  The only way to get back to the status bar is to swipe down, select the Overlap button (to hide the overlap control) and then swipe up.  The swipe up operation is not universal - if you try swiping up from an item that is grayed out (for example, terrain awareness), you go into a modal dialog box that blocks everything until you read the "Terrain awareness is available..." message and dismiss the dialog.  The menu doesn't disappear - you have to swipe up on a spot that doesn't have an underlying dialog pop up.  And you have to understand/remember how you got to your position in the menu hierarchy.

Meantime, flight status information is either hidden, or portions of it are appearing at the bottom of menus that change whenever you select a menu.

The instructions say that the back button (circle with a left arrow) "returns to the previous menu."  This is misleading - it doesn't take you out of the camera sub menu, but rather it takes you entirely out of the Map Pilot active app, disconnects you from the aircraft, and opens up the main entry screen to start a new mission, adjust settings, etc.  

At this point, I tried to "create new mission" and it said I had a mission in progress. I waited for a minute or two, expecting the aircraft to reconnect, but nothing happened.  I pressed the RTH button, and didn't notice anything, (the aircraft was about a 1000' away, down sun, so it was very hard to see)  I pressed it again, which I now I realize now that this might have cancelled the original RTH.  At that point, I switched to the A mode position, which was too late, and I lost my drone... probably within an 20 acre area.

There are of course two sides to this issue.  One is RTFM ("Read The Fine Manual") which explicitly says to switch to A mode to recover the aircraft.  For example, 767 aircraft used to have an engine cutoff switch next to the landing gear deployment switch.  Of course, pilots should read the manual and use the right switch.

The other side is that software designers should pay attention to the user interface - not hiding situational awareness indicators with pull-out menus.  Not locking users into dialog boxes that block access to other controls.  Not moving critical status information around the menu system, and changing it as the menu hierarchy changes.  Not having a "menu return" button that disconnects the Map Pilot from the aircraft.  Not hiding menus with unintuitive access modes (tap the status bar to see the camera menu; swipe the menu to close it, but only swipe from certain areas of the menu.)

I'm not a happy camper :)

 

Tom

Please sign in to leave a comment.