Post

2 followers Follow
0
Avatar

Drone stops mid air during the mission ( DJI Phantom 3 Professional)

Hi,
your app worked fine for there weeks.

However, starting two weeks ago , the drone would stop in mid flight and just hover up in the air. I tried to hit the stop button and then press cont. button to restart it but to no avail. It will just hover up there. Then I I would hit the home button, land it and re-start the mission. The drone would go to location where the mission was stopped and would continue from that point to complete the mission. I thought problem solved.
However, last two days it got worst. It would just take two turns (whilie taking images) and then it would stop and hover.
I changed the location of the flight , altitude , duration of the mission, time of the day ( different light exposures), but nothing helped.
Can you please explain to me what is going on? I am really confused.
I used waypoints method with DJI app and had no problems completing the mission. I also had flew it manually on P and F with no problem. So I would say that controls and GPS of the drone is ok.
What is going on?
Cold weather ?
Bug?

Matija Radovic

Official comment

Avatar

It is interesting that it was fine previously and is now stopping. We have heard reports of this a few times and suspect that it is firmware related since all Map Pilot does is load waypoints into the aircraft and off it goes. Map Pilot seems to expose the problem more than the DJI Go app does since it allows longer flights and gets used more. Also, DJI uses its own methods for loading the waypoints. We hope to have a new release that is based on a new SDK release in the next week or so. Hopefully it will address the issue.

Sorry for the issues.

Tudor
Comment actions Permalink

Please sign in to leave a comment.

4 comments

0
Avatar

Phantom_3_Professional_Firmware_v1.4.0010_en

which is the newest version. I just upgraded it few weeks ago

Matija Radovic 0 votes
Comment actions Permalink
0
Avatar

We ask because a lot of people are using a newer development firmware. Also, there is a new version out for the P3. The latest public version is 1.5.0030. We are updating a few things to reflect some of the latest capabilities.

We don't know if the stopping issue has been fixed in the new version yet. Please update and let us know.

Tudor 0 votes
Comment actions Permalink