Post

8 followers Follow
0
Avatar

Multi-battery mission sometimes not resuming at correct location

I've flown a few mission now where I had to change the battery out two or three times. I've had a couple successful continuations after relaunching, however, half the time (so far), even though the blue abandonment point is dropped in the correct location, the Phantom 3 (on the next flight) begins taking pictures once it hits cruise altitude, and then makes a bee line for the END of the grid path (the same grid line path it was on when I commanded an RTH previously), instead of flying back to where the blue dot is, and continuing the path from there.

Has anyone else had this experience? Is there a way I can avoid this in the future? So far it seems to be a random occurrence (albeit twice out of five battery changes). I basically end up with a gap on that leg. I suppose a work-around is to always RTH at the end of a leg; but was wondering if this was a known bug that was being worked on?

I did take a screen shot, but don't know how to upload it here.

Thanks.

Stephen Hurd

Official comment

Avatar

A fix for this has been found and is being tested. It will be in the next release which we hope to have out soon.

It seems to be related to the new firmware and flipping out of F mode to land manually. It is basically moving the Point of Abandonment to where the manual control was taken. If you just leave it in F mode and make manual adjustments it shouldn't happen. Our fix will make it so it will be able to be fully taken over for landing without affecting the current POA.

Tudor
Comment actions Permalink

Please sign in to leave a comment.

10 comments

0
Avatar

I cant find any documentation on multi-battery missions. Do you have a link, or do you want to explain how it works. I assume once battery hits low lever, or a predefined time (ie: 18mins) the UAV returns home and starts to auto land. You'd switch it off, replace battery and boot it up, then resume the mission. With DJI Inspire 1, you have to manually get to 5m AGL to start a mission (not autonomous like a phantom unfortunately, so do you 'resume' once you are at 5m? Any assistance would help Stephen, i'm only new at this (2 days use)

nic 0 votes
Comment actions Permalink
-1
Avatar

Nic,

The UAV will return home at critical battery level (if you've set your failsafe to do so with the Go App previously). You can also have it come home by tapping the 'home' icon or pressing the rth button the RC. Just don't switch out of 'F' mode, or you'll loose the mission. You have to fly the Phantom 3 off the ground 5m as well, before it will accept a mission. Also, don't turn your RC unit off when changing batteries or disconnect your iPad.

Stephen Hurd -1 votes
Comment actions Permalink
0
Avatar

Same issue , first multi battery flight last week ( AND did not go nicely to home after battery was empty !, but quickly puched the go home button and needed to land it manual ) But i got the blue marking.

After resume the flight it started making pciture after start and did go to the beginning of the next waypoint but misses the blue point totally
I did create an extra mission to make sure i had enough pictures to finish the project

I also have a screenshot but i don't know where to upload it to.

Bert Bosman 0 votes
Comment actions Permalink
0
Avatar

Bert, thanks for emailing in your screenshot. We are trying to duplicate the issue.

Tudor 0 votes
Comment actions Permalink
0
Avatar

Hi there, I've just flown a multi bat mission. (2 batteries) and I had the exact same thing happen. First mission went perfect, flew back home when bat hit 20%, changed battery and up it went. then at altitude it headed to the end of a flight line opposite to the abandonment point and started taking pictures at altitude and it also skipped the last flight line it abandoned on. Not sure what to do? I ended up manually navigating where it missed and tried to take pictures manual to fill the gaps. Otherwise I love the app.

Upland 0 votes
Comment actions Permalink
0
Avatar

Is this issues addressed in the latest version ? ( dd 28-01-2016)

Bert Bosman 0 votes
Comment actions Permalink
0
Avatar

I had this happened also. The drone after the battery change, upload the mission again went to the blue dot and then follow the rest of the line without taking pictures instead it took pictures in the line of getting home. But the problem was that I forgot to revert the switch to P mode (Phantom 4) and landed it ATTI mode (which lead to a rough landing by the way).

I will test again in the next flight to see if landing to P mode corrects the problem.

George 0 votes
Comment actions Permalink