Post

3 followers Follow
0
Avatar

M600 PRO with X5 not recognized by app

Today, after some time, I took my M600 PRO with X5 and tried to do a mapping mission.

No matter what I did, I couldn't get the drone go.

All firmwares are up to date, MP shows the red drone position triangle, sasy: Connected to M600 PRO, the GPS leds are green but there are no upload or other buttons to start the mission.

I can even move the gimbal, which I see in the preview window.

I switched the RC and the bird and the tablet off and on but nothing.

Is it just me, or is MP getting worser?

Dario Finderle

Official comment

Avatar

DJI has been changing a ton of things in the firmware lately and it is nearly impossible to keep up for all the models. 

Please post a screenshot of when it says "Connected to M600 PRO". If that PRO is capitalized that would likely be the problem since we key in off of the aircraft identifier string and it used to be in lower case letters... Fun.

Zane

Please sign in to leave a comment.

14 comments

0
Avatar

To be clear: You can see the video feed in the camera preview panel, correct? It just isn't letting you upload and take off?

Zane 0 votes
0
Avatar

Yes, I see the video feed.

Right now I can't make the screenshots but I'll do them tomorrow and put them here.

Really not shure if the PRO was capitalized or not, but more on the YES side

Dario Finderle 0 votes
0
Avatar

Full, it was open space, belive 14 or so. I tried to switch to DJI GO and could fly, the killed DJI GO, but nothing.

Dario Finderle 0 votes
0
Avatar

I don't have another DJI camera.

I would love to trigger a Sony, but you are not selling only your trigger device :)

Dario Finderle 0 votes
0
Avatar

Does it work with the camera disconnected? Basically we are trying to see if the issue is caused by the X5 or the m600 Pro. We are trying to get a system together to test with.

 

Zane 0 votes
0
Avatar

I did not try. As I can remember from before, MP would not start a mission without an attached camera.

Newertheless, then X5 sucks for serious mapping. I also wanted to try if MP triggers the F ports parallel to triggering the X5. Could it be the problem that one of the F ports is set to Shutter? 

Dario Finderle 0 votes
0
Avatar

After tests on different both the iPhone 6 and iPad Mini 4, the Matrice 600 Pro with X5 is verified as working.

All the latest firmware versions are as follows:

  • App: 3.1.13
  • Aircraft: 1.00.01.20
  • RC: 1.2.10
  • X5 Camera: 1.11.1.50
  • LB2 Air: 1.1.60
  • Map Pilot App: 2.5.3 build 06212017.

Please verify that all versions and apps are up to date and match above.

Ryan 0 votes
0
Avatar

Ryan,

Aircraft, LB2 Air / MapPilot are OK.

Where is the RC version and what App do you mean?

I also checked the X5 version which is 1.11.1.40. The .50 version is integrated in the Inspire firmware and I don't know how to upgrade it.

Dario Finderle 0 votes
0
Avatar

All firmware except for Map Pilot can be found in DJI Go. 

DJI Go > General Settings (...) > About > Firmware versions and Flight Controller Serial number. 

The X5 was just upgraded for testing on the Inspire 1 V2.0. You should still be able to download the firmware off DJI download page for the X5.

Ryan 0 votes
0
Avatar

Ryan,

there is no stand-alone version for X5 FW upgrade.

Tried the Inspire version, but it gives me errors. I've contacted DJI support and am waiting for their response.

Dario Finderle 0 votes